03 OCAK 2017
SALI
01.47
Excel'de Önemli Fonksiyonlar

Excel, birçok yazılım dili öğrenilerek yapılabilecek işlemleri, kendi içerisinde çok daha basite indirgeyerek kullanıcıya fonksiyonlar yardımı ile daha kolay işlem imkanı sunar. Bu özelliği ile de birçok işi hızlandırır, hesaplamalar dışında grafikler oluşturarak gelişimleri veya ne yönde yatırım yapılırsa daha iyi olur gibi birçok fikri size sunabilir.

Temelinde basit matematik işlemleri yatsa dahi, her yazılım dilinde olmazsa olmazlar vardır. İşte Excel'de bu olmazsa olmaları toplayarak kendi içerisinde fonksiyonlar başlığı altında sıralamıştır. Bu konu başlığı altında özel olarak seçtiğim birkaç fonksiyonu göreceğiz.

 

1) TOPLA (SUM)

TOPLA fonksiyonumuz ile belirlediğimiz aralıktaki iki hücreyi veya sayıyı toplayabiliriz.
=TOPLA(5;10)
=SUM(5;10)
=TOPLA(A1;A2)
=SUM(A1;A2)

2) ÇARPIM (PRODUCT)

ÇARPIM fonksiyonumuz ile belirlediğimiz aralıktaki iki hücreyi veya sayıyı çarpabiliriz.
=ÇARPIM(5;10)
=PRODUCT(5;10)
=ÇARPIM(A1;A2)
=PRODUCT(A1;A2)

3) BÖLÜM (QUOTIENT)

BÖLÜMfonksiyonumuz ile belirlediğimiz aralıktaki iki hücreyi veya sayıyı bölebiliriz.
=BÖLÜM(5;10)
=QUOTIENT(5;10)
=BÖLÜM(A1;A2)
=QUOTIENT(A1;A2)

4) ORTALAMA (AVERAGE)

ORTALAMA fonksiyonumuz ile iki veya daha fazla sayının ortalamasını alabiliriz.
=ORTALAMA(5;10)
=AVERAGE(5;10)
=ORTALAMA(A1;A2)
=AVERAGE(A1;A2)

5) EĞERSAY (COUNTIF)

EĞERSAY fonksiyonumuz ile belirlediğimiz aralıkta belirlediğimiz ögeden kaç tane olduğunu saydırabiliriz.
=EĞERSAY(A9:A11; "Mert")
=COUNTIF(A9:A11; "Mert")

Örneğimizde A9, A10 ve A11 hücrelerindeki metinlerde kaç adet "Mert" olduğunu saydırabiliriz.

6) PARÇAAL (MID)

PARÇAAL fonksiyonumuz ile belirlenen bir metnin seçtiğimiz bir parçasını alabiliriz.
=PARÇAAL("MERT TOPUZ";6;5)
=MID("MERT TOPUZ";6;5)

Örneğimizde "MERT TOPUZ" metninden '6. karakterden sonraki 5 karakteri yazdır' demiş oluyoruz. Bu da "TOPUZ" çıktısı verecektir.

7) SOLDAN (LEFT)

SOLDAN fonksiyonumuzu aslında PARÇAAL fonksiyonunun bir başka versiyonu olarak düşünebiliriz. Bu kez baştan başlayarak kaç karakter gidileceğini seçmiş oluyoruz.
=SOLDAN("MERT TOPUZ";4)
=LEFT("MERT TOPUZ";4)

Örneğimizde "MERT TOPUZ" metninin 'başından başlayarak ilk 4 karakteri yazdır' demiş oluyoruz. Bu da "MERT" çıktısı verecektir.

8) SAĞDAN (RIGHT)

SAĞDAN fonksiyonumuz SOLDAN fonksiyonumuzun tam tersidir. SAĞDAN fonksiyonumuz ile de girilen metnin sonundan belli karakter seçebiliriz.
=SAĞDAN("MERT TOPUZ";5)
=RIGHT("MERT TOPUZ";5)

Örneğimizde "MERT TOPUZ" metninin 'sonundan başlayarak geriye doğru 5 karakteri yazdır' demiş oluyoruz. Bu da "TOPUZ" çıktısı verecektir.

9) YİNELE (REPT)

YİNELE fonksiyonu ile belirttiğimiz karakteri belirttiğimiz sayıda tekrarlatabiliriz.
=YİNELE("MERT";5)
=REPT("MERT";5)

Örneğimiz yardımı ile ekrana 5 kez MERT yazdırmış olduk.

10) UZUNLUK (LEN)

UZUNLUK fonksiyonu ile girilen değerin kaç karakterden oluştuğunu öğrenebiliriz.
=UZUNLUK("MERT TOPUZ")
=LEN("MERT TOPUZ")

Örneğimizde sonuç 10 karakter olarak çıkacaktır. Boşlukların sayıldığını unutmayalım :)

11) BÜYÜKHARF (UPPER)

BÜYÜKHARF fonksiyonu ile varolan metnin tüm karakterlerini büyük harfe çevirebiliriz.
=BÜYÜKHARF("mert topuz")
=UPPER("mert topuz")

12) KÜÇÜKHARF (LOWER)

KÜÇÜKHARF fonksiyonu ile varolan metnin tüm karakterlerini küçük harfe çevirebiliriz.
=KÜÇÜKHARF("MERT TOPUZ")
=LOWER("MERT TOPUZ")

13) KAREKÖK (SQRT)

KAREKÖK fonksiyonu ile girilen değerin karekökünü öğrenebiliriz.
=KAREKÖK(25)
=SQRT(25)

14) Pİ (PI)

Pİ fonksiyonu, Pi sayısının çıktısını verir. Matematiksel işlemlerde bolca kullanılır :)
=Pİ()
=PI()

15) MOD (MOD)

MOD fonksiyonu, bir sayının bir başka sayıya bölümünden kalanı ekrana yazdırır.
=MOD(5;3)
=MOD(5;3)

Örneğimizde 5 sayısının 3 sayısına bölümünden kalan 2 ekrana yazılacaktır.

YORUMLAR 2
1
Mert Topuz
26 NİSAN 2017 - 18.19
@Muhammet Ali GÖKDEMİR, kesinlikle fonksiyonları bilmek şart :) Günümüzde birçok dilde bu işlemler için zaman harcarken basit işlerimizi Excel aracılığı ile rahatlıkla görebiliriz aslında
CEVAPLA
0
Muhammet Ali GÖKDEMİR
25 NİSAN 2017 - 22.34
Excel hakkında çok güzel bilgiler vermişsiniz teşekkürler :) Fonksiyonları bilmek şart, çoğu işte kolaylık sağlıyor.
CEVAPLA
YORUM BIRAK
Şuanda bu yoruma cevap yazıyorsunuz:
İptal Et