03 OCAK 2017
SALI
02.18
Excel ile Görünmez Ad ve Soyad

Günümüzde üniversitelerde not asılan panolarda isim ve soyisimlerin yerinde ismin ve soyadının ilk 2 hanesi ve devamında isim ve soyad uzunluğunca * karakterinin geldiğine şahit olmuşsunuzdur. Bunu günlük hayatımızda farklı yerlerde de görmüş olabiliriz. Bu konumuzda bu olayın Excel ile nasıl formüle döküldüğünü işleyeceğiz. Konunun en altından ilgili dökümanı indirip kendiniz kontrol edebilirsiniz.

 

Formül

  1. ADIM:  

Formülün tamamı aşağıdaki gibidir. Fakat biz formülü parçalara ayırarak inceleyeğiz. Bu sebeple öncelikli olarak aşağıdaki yapımızı iki farklı alana farklı renklerde bölerek gösterdik.

=SOLDAN(A3;2)&YİNELE("*";UZUNLUK(A3)-2) & " " & SOLDAN(B3;2)&YİNELE("*";UZUNLUK(B3)-2)

  2. ADIM:  

Formülün ilk kısmını ele alalım;

SOLDAN(A3;2)&YİNELE("*";UZUNLUK(A3)-2)

İlk olarak bakmamız gereken formül bize ne söylüyor? Burada gözlemliyoruz ki formülümüzün içerisinde SOLDAN, YİNELE ve UZUNLUK adında 3 farklı fonksiyon yer almaktadır. Buradaki link yardımı ile bu fonksiyonların anlamlarına ulaşabilirsiniz.

SOLDAN(A3;2) : A3 hücresinde yer alan karakterimizin soldan 2 basamağını al.
Yani bize diyor ki: Mert metninin ilk 2 karakterini alalım ve yazdıralım: Me

YİNELE("*";UZUNLUK(A3)-2) : Yinele fonksiyonumuz ile * (yıldız) karakterini UZUNLUK(A3)-2 kadar tekrar et diyoruz.
Yani bize diyor ki: UZUNLUK(A3)-2 ] A3 hücremizde "Mert" yazıyor ve Uzunluk fonksiyonu ile "Mert" metninin karakter sayısını öğreniyoruz: 4
Öğrendiğimiz bu karakter sayısından [ UZUNLUK(A3)-2 ] 2 çıkartalım diyor: 4-2 = 2
Yani sonuç olarak YİNELE fonksiyonu ile * (yıldız) karkaterini 2 kez tekrarla demiş olduk: **

Buraya kadar olan alanda fonksiyonumuzun ilk kısmını tamamladık. Ve ekranımızda şu yazıyor: Me**

  3. ADIM:  

Formülün arasındaki metni ele alalım.

Formülü ikiye bölme sebebimiz aslında bu alan.. İsim ve soyad arasında boşluk bırakmak için & " " & bu ifadeyi kullanıyoruz. İfadede yer alan & işaretleri metin birleştirme operatörü olarak biliniyor. Tırnak içine yazdıklarımızda bir metin olarak ele alındığından tırnak içinde boşluk bırakarak isim ve soyad arasında boşluk koymuş oluyoruz.

  4. ADIM:  

Formülün kalan ksımını ele alalım.

SOLDAN(B3;2)&YİNELE("*";UZUNLUK(B3)-2)

Aslına bakarsak formülü incelediğimizde 2. Adımdaki formül ile tek farkının dikkate alınan hücrelerin farklı oluşu olduğunu göreceğiz. Bu sebeple de 2. adımda ne yaptıysak aynı işlemlerden geçen formül bize sonuçta çıktı olarak şunu döndürecektir: To***

 

Bu sayede istediğimiz durumu gerçekleştirmiş ve sonuç olarak Kişi Adı ve Kişi Soyadı sütunlarında yer alan verileri Görünmez Ad ve Soyad sütununda * işaretleri ile gizlemiş olduk. Dosyaya aşağıdaki linkten ulaşabilirsiniz.

YORUMLAR 2
0
Mahmut ŞEN
02 HAZİRAN 2020 - 10.54
Ad Soyad aynı hücrede olursa da aşağıdaki formül kullanılabilir: örneğin a1 de ad soyad olsun B1 ü formmülü yapıştırabiliriz: ------------ =EĞER(A1="";"lütfen ad soyad giriniz";EĞER(UZUNLUK(KIRP(A1)
CEVAPLA
1
murat balta
23 OCAK 2020 - 14.48
merhabalar sen nasıl mükemmel bir insansın ya? Çok teşekkürler....
CEVAPLA
0
Mert Topuz
25 OCAK 2020 - 02.12
Çok teşekkürler :) İşinize yaramasına sevindim
YORUM BIRAK
Şuanda bu yoruma cevap yazıyorsunuz:
İptal Et